import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:from\\s+(\\w+)(?:\\.\\w+)?\\s+)?import\\s+([^\\s,.]+)(?:\\.\\w+)?";
final String string = "import numpy as np\n"
+ "import pandas as pd\n"
+ "import pkg.mod1, pkg.mod2\n"
+ "from pkg.mod2 import Bar as Qux\n"
+ "from abc.lmn import pqr\n"
+ "from abc.lmn import pqr as xyz\n"
+ "import mod\n"
+ "from mod import s, foo\n"
+ "from mod import *\n"
+ "from pkg.mod3 import *\n"
+ "from mod import s as string, a as alist\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}