#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<style>[\x00-\xFF]+<\/style>"
Local $sString = "" & @CRLF & _
" <style>" & @CRLF & _
" html, body {" & @CRLF & _
" position: absolute;" & @CRLF & _
" margin: 0;" & @CRLF & _
" padding: 0;" & @CRLF & _
" width: 100%;" & @CRLF & _
" height: 100%;" & @CRLF & _
" }" & @CRLF & _
" </style>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")