re = /<style>[\x00-\xFF]+<\/style>/m
str = '
<style>
html, body {
position: absolute;
margin: 0;
padding: 0;
width: 100%;
height: 100%;
}
</style>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end