import re
regex = re.compile(r"<style>[\x00-\xFF]+<\/style>", flags=re.MULTILINE)
test_str = ("\n"
" <style>\n"
" html, body {\n"
" position: absolute;\n"
" margin: 0;\n"
" padding: 0;\n"
" width: 100%;\n"
" height: 100%;\n"
" }\n"
" </style>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")