using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<style>[\x00-\xFF]+<\/style>";
string input = @"
<style>
html, body {
position: absolute;
margin: 0;
padding: 0;
width: 100%;
height: 100%;
}
</style>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}