using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<)?text(?(1)>?|>)";
string substitution = @"";
string input = @"text
<text
texdfdft>
<fdfd>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}