re = /(<)?text(?(1)>?|>)/m
str = 'text
<text
texdfdft>
<fdfd>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result