const regex = /(<)?text(?(1)>?|>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<)?text(?(1)>?|>)', 'gm')
const str = `text
<text
texdfdft>
<fdfd>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);