$re = '/(<)?text(?(1)>?|>)/m';
$str = 'text
<text
texdfdft>
<fdfd>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;