#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[Гг]енеральный.[Дд]иректор.+|[Гг]енеральный.[Дд]иректор\n.+|[Рр]уководитель.*|^[Дд]иректор[\s\S].+|Директор .*?[А-Я].*?[А-Я].*?[А-Я].*?|Директор.([А-ЯЁ][а-яё]*(?:-[А-ЯЁ][а-яё]*)? [А-ЯЁ][а-яё]*(?:-[А-ЯЁ][а-яё]*)? [А-ЯЁ][а-яё]*(?:-[А-ЯЁ][а-яё]*)?)"
Local $sString = "Генеральный директор В. В. ВАС" & @CRLF & _
"Должность Генеральный директор" & @CRLF & _
"Ф.И.О. Васил В.В." & @CRLF & _
"Руководитель (должность, ФИО) Васил Василий Васильевич" & @CRLF & _
"Директор - - Васил Василий Васильевич Коммерческий директор – Васил Василий Васильевич"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")