$re = '/[Гг]енеральный.[Дд]иректор.+|[Гг]енеральный.[Дд]иректор\n.+|[Рр]уководитель.*|^[Дд]иректор[\s\S].+|Директор .*?[А-Я].*?[А-Я].*?[А-Я].*?|Директор.([А-ЯЁ][а-яё]*(?:-[А-ЯЁ][а-яё]*)? [А-ЯЁ][а-яё]*(?:-[А-ЯЁ][а-яё]*)? [А-ЯЁ][а-яё]*(?:-[А-ЯЁ][а-яё]*)?)/m';
$str = 'Генеральный директор В. В. ВАС
Должность Генеральный директор
Ф.И.О. Васил В.В.
Руководитель (должность, ФИО) Васил Василий Васильевич
Директор - - Васил Василий Васильевич Коммерческий директор – Васил Василий Васильевич';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);