package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[Гг]енеральный.[Дд]иректор.+|[Гг]енеральный.[Дд]иректор\n.+|[Рр]уководитель.*|^[Дд]иректор[\s\S].+|Директор .*?[А-Я].*?[А-Я].*?[А-Я].*?|Директор.([А-ЯЁ][а-яё]*(?:-[А-ЯЁ][а-яё]*)? [А-ЯЁ][а-яё]*(?:-[А-ЯЁ][а-яё]*)? [А-ЯЁ][а-яё]*(?:-[А-ЯЁ][а-яё]*)?)`)
var str = `Генеральный директор В. В. ВАС
Должность Генеральный директор
Ф.И.О. Васил В.В.
Руководитель (должность, ФИО) Васил Василий Васильевич
Директор - - Васил Василий Васильевич Коммерческий директор – Васил Василий Васильевич`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}