// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[Гг]енеральный.[Дд]иректор.+|[Гг]енеральный.[Дд]иректор\n.+|[Рр]уководитель.*|^[Дд]иректор[\s\S].+|Директор .*?[А-Я].*?[А-Я].*?[А-Я].*?|Директор.([А-ЯЁ][а-яё]*(?:-[А-ЯЁ][а-яё]*)? [А-ЯЁ][а-яё]*(?:-[А-ЯЁ][а-яё]*)? [А-ЯЁ][а-яё]*(?:-[А-ЯЁ][а-яё]*)?)").unwrap();
let string = "Генеральный директор В. В. ВАС
Должность Генеральный директор
Ф.И.О. Васил В.В.
Руководитель (должность, ФИО) Васил Василий Васильевич
Директор - - Васил Василий Васильевич Коммерческий директор – Васил Василий Васильевич";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}