#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)STOP_DATE.+?VALUE\s*=\s*\"(.+?)\""
Local $sString = "GROUP = TEMPORALINFORMATION" & @CRLF & _
"" & @CRLF & _
"OBJECT = PRODUCTIONDATETIME" & @CRLF & _
" NUM_VAL = 1" & @CRLF & _
" VALUE = "2015-07-19T18:29:43Z"" & @CRLF & _
"END_OBJECT = PRODUCTIONDATETIME" & @CRLF & _
"" & @CRLF & _
"OBJECT = START_DATE" & @CRLF & _
" NUM_VAL = 1" & @CRLF & _
" VALUE = "2015-07-11T20:17:22Z"" & @CRLF & _
"END_OBJECT = START_DATE" & @CRLF & _
"" & @CRLF & _
"OBJECT = STOP_DATE" & @CRLF & _
" NUM_VAL = 1" & @CRLF & _
" VALUE = "2015-07-11T21:03:52Z"" & @CRLF & _
"END_OBJECT = STOP_DATE" & @CRLF & _
"" & @CRLF & _
"END_GROUP = TEMPORALINFORMATION"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")