# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"STOP_DATE.+?VALUE\s*=\s*\"(.+?)\""
test_str = ("GROUP = TEMPORALINFORMATION\n\n"
"OBJECT = PRODUCTIONDATETIME\n"
" NUM_VAL = 1\n"
" VALUE = \"2015-07-19T18:29:43Z\"\n"
"END_OBJECT = PRODUCTIONDATETIME\n\n"
"OBJECT = START_DATE\n"
" NUM_VAL = 1\n"
" VALUE = \"2015-07-11T20:17:22Z\"\n"
"END_OBJECT = START_DATE\n\n"
"OBJECT = STOP_DATE\n"
" NUM_VAL = 1\n"
" VALUE = \"2015-07-11T21:03:52Z\"\n"
"END_OBJECT = STOP_DATE\n\n"
"END_GROUP = TEMPORALINFORMATION")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.