import Foundation
let pattern = #"STOP_DATE.+?VALUE\s*=\s*\"(.+?)\""#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
GROUP = TEMPORALINFORMATION
OBJECT = PRODUCTIONDATETIME
NUM_VAL = 1
VALUE = "2015-07-19T18:29:43Z"
END_OBJECT = PRODUCTIONDATETIME
OBJECT = START_DATE
NUM_VAL = 1
VALUE = "2015-07-11T20:17:22Z"
END_OBJECT = START_DATE
OBJECT = STOP_DATE
NUM_VAL = 1
VALUE = "2015-07-11T21:03:52Z"
END_OBJECT = STOP_DATE
END_GROUP = TEMPORALINFORMATION
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}