using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"STOP_DATE.+?VALUE\s*=\s*\""(.+?)\""";
string input = @"GROUP = TEMPORALINFORMATION
OBJECT = PRODUCTIONDATETIME
NUM_VAL = 1
VALUE = ""2015-07-19T18:29:43Z""
END_OBJECT = PRODUCTIONDATETIME
OBJECT = START_DATE
NUM_VAL = 1
VALUE = ""2015-07-11T20:17:22Z""
END_OBJECT = START_DATE
OBJECT = STOP_DATE
NUM_VAL = 1
VALUE = ""2015-07-11T21:03:52Z""
END_OBJECT = STOP_DATE
END_GROUP = TEMPORALINFORMATION";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}