#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)\\(\*)|\*(?=.*(\\\*))"
Local $sString = "\*test\*" & @CRLF & _
"*test*" & @CRLF & _
"\*test\*" & @CRLF & _
"other text" & @CRLF & _
"*test*" & @CRLF & _
"\*test\*" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"\*"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)