using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\(\*)|\*(?=.*(\\\*))";
string substitution = @"$1$2";
string input = @"\*test\*
*test*
\*test\*
other text
*test*
\*test\*
\*";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}