re = /\\(\*)|\*(?=.*(\\\*))/m
str = '\\*test\\*
*test*
\\*test\\*
other text
*test*
\\*test\\*
\\*'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result