use strict;
my $str = '\\*test\\*
*test*
\\*test\\*
other text
*test*
\\*test\\*
\\*';
my $regex = qr/\\(\*)|\*(?=.*(\\\*))/msp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";