#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\G(?!\A)|Acheminement conso)[\s\S]*?\KHeure Pleine Saison Basse"
Local $sString = "Electricité n° de\n" & @CRLF & _
"compteur ancien\n" & @CRLF & _
"index nouvel\n" & @CRLF & _
"index conso\n" & @CRLF & _
"kWh/Qté prix unitaire\n" & @CRLF & _
"HT en euros montant HT\n" & @CRLF & _
"en euros taux de\n" & @CRLF & _
"TVA\n" & @CRLF & _
"Contribution cee du 14/07/22 au 13/08/22 143020,00495 70,7920,0%\n" & @CRLF & _
"Evolutions arenh du 14/07/22 au 13/08/22 14302-0,03149 -450,3720,0%\n" & @CRLF & _
"Consommation du 14/07/22 au 13/08/22 154\n" & @CRLF & _
"Heure Pleine Saison Basse 1" & @CRLF & _
"Heure Pleine Saison Basse 2" & @CRLF & _
"Heure Creuse Saison Basse 2" & @CRLF & _
"Acheminement conso\n" & @CRLF & _
"kWh/Qté prix unitaire\n" & @CRLF & _
"HT en euros montant HT\n" & @CRLF & _
"en euros taux de\n" & @CRLF & _
"TVA\n" & @CRLF & _
"Composante de comptage du 1" & @CRLF & _
"Composante de comptage du 2" & @CRLF & _
"Composante de soutirage du 1" & @CRLF & _
"Composante de soutirage du 2" & @CRLF & _
"Composante de gestion 1" & @CRLF & _
"Composante de gestion 2" & @CRLF & _
"Consommation du 14/07/22 au 31/07/22 Heure Pleine Saison Basse 56200,02000 112,4020,0%\n" & @CRLF & _
"Heure Creuse Saison Basse 26840,01700 45,6320,0%\n" & @CRLF & _
"Consommation du 01/08/22 au 13/08/22\n" & @CRLF & _
"Heure Pleine Saison Basse 3" & @CRLF & _
"Heure Creuse Saison Basse 4" & @CRLF & _
"Heure Pleine Saison Basse 5" & @CRLF & _
"Heure Pleine Saison Basse 6" & @CRLF & _
"Heure Pleine Saison Basse 7" & @CRLF & _
"Services et prestations techniques conso\n" & @CRLF & _
"kWh/Qté prix unitaire\n" & @CRLF & _
"HT en euros montant HT\n" & @CRLF & _
"en euros taux de\n" & @CRLF & _
"TVA\n" & @CRLF & _
"Espace Client Gratuit\n" & @CRLF & _
"Taxes et Contributions conso\n"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")