# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\G(?!\A)|Acheminement conso)[\s\S]*?\KHeure Pleine Saison Basse"
test_str = ("Electricité n° de\\n\n"
"compteur ancien\\n\n"
"index nouvel\\n\n"
"index conso\\n\n"
"kWh/Qté prix unitaire\\n\n"
"HT en euros montant HT\\n\n"
"en euros taux de\\n\n"
"TVA\\n\n"
"Contribution cee du 14/07/22 au 13/08/22 143020,00495 70,7920,0%\\n\n"
"Evolutions arenh du 14/07/22 au 13/08/22 14302-0,03149 -450,3720,0%\\n\n"
"Consommation du 14/07/22 au 13/08/22 154\\n\n"
"Heure Pleine Saison Basse 1\n"
"Heure Pleine Saison Basse 2\n"
"Heure Creuse Saison Basse 2\n"
"Acheminement conso\\n\n"
"kWh/Qté prix unitaire\\n\n"
"HT en euros montant HT\\n\n"
"en euros taux de\\n\n"
"TVA\\n\n"
"Composante de comptage du 1\n"
"Composante de comptage du 2\n"
"Composante de soutirage du 1\n"
"Composante de soutirage du 2\n"
"Composante de gestion 1\n"
"Composante de gestion 2\n"
"Consommation du 14/07/22 au 31/07/22 Heure Pleine Saison Basse 56200,02000 112,4020,0%\\n\n"
"Heure Creuse Saison Basse 26840,01700 45,6320,0%\\n\n"
"Consommation du 01/08/22 au 13/08/22\\n\n"
"Heure Pleine Saison Basse 3\n"
"Heure Creuse Saison Basse 4\n"
"Heure Pleine Saison Basse 5\n"
"Heure Pleine Saison Basse 6\n"
"Heure Pleine Saison Basse 7\n"
"Services et prestations techniques conso\\n\n"
"kWh/Qté prix unitaire\\n\n"
"HT en euros montant HT\\n\n"
"en euros taux de\\n\n"
"TVA\\n\n"
"Espace Client Gratuit\\n\n"
"Taxes et Contributions conso\\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.