use strict;
my $str = 'Electricité n° de\\n
compteur ancien\\n
index nouvel\\n
index conso\\n
kWh/Qté prix unitaire\\n
HT en euros montant HT\\n
en euros taux de\\n
TVA\\n
Contribution cee du 14/07/22 au 13/08/22 143020,00495 70,7920,0%\\n
Evolutions arenh du 14/07/22 au 13/08/22 14302-0,03149 -450,3720,0%\\n
Consommation du 14/07/22 au 13/08/22 154\\n
Heure Pleine Saison Basse 1
Heure Pleine Saison Basse 2
Heure Creuse Saison Basse 2
Acheminement conso\\n
kWh/Qté prix unitaire\\n
HT en euros montant HT\\n
en euros taux de\\n
TVA\\n
Composante de comptage du 1
Composante de comptage du 2
Composante de soutirage du 1
Composante de soutirage du 2
Composante de gestion 1
Composante de gestion 2
Consommation du 14/07/22 au 31/07/22 Heure Pleine Saison Basse 56200,02000 112,4020,0%\\n
Heure Creuse Saison Basse 26840,01700 45,6320,0%\\n
Consommation du 01/08/22 au 13/08/22\\n
Heure Pleine Saison Basse 3
Heure Creuse Saison Basse 4
Heure Pleine Saison Basse 5
Heure Pleine Saison Basse 6
Heure Pleine Saison Basse 7
Services et prestations techniques conso\\n
kWh/Qté prix unitaire\\n
HT en euros montant HT\\n
en euros taux de\\n
TVA\\n
Espace Client Gratuit\\n
Taxes et Contributions conso\\n';
my $regex = qr/(?:\G(?!\A)|Acheminement conso)[\s\S]*?\KHeure Pleine Saison Basse/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}