const regex = /(?:\G(?!\A)|Acheminement conso)[\s\S]*?\KHeure Pleine Saison Basse/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A)|Acheminement conso)[\\s\\S]*?\\KHeure Pleine Saison Basse', 'gm')
const str = `Electricité n° de\\n
compteur ancien\\n
index nouvel\\n
index conso\\n
kWh/Qté prix unitaire\\n
HT en euros montant HT\\n
en euros taux de\\n
TVA\\n
Contribution cee du 14/07/22 au 13/08/22 143020,00495 70,7920,0%\\n
Evolutions arenh du 14/07/22 au 13/08/22 14302-0,03149 -450,3720,0%\\n
Consommation du 14/07/22 au 13/08/22 154\\n
Heure Pleine Saison Basse 1
Heure Pleine Saison Basse 2
Heure Creuse Saison Basse 2
Acheminement conso\\n
kWh/Qté prix unitaire\\n
HT en euros montant HT\\n
en euros taux de\\n
TVA\\n
Composante de comptage du 1
Composante de comptage du 2
Composante de soutirage du 1
Composante de soutirage du 2
Composante de gestion 1
Composante de gestion 2
Consommation du 14/07/22 au 31/07/22 Heure Pleine Saison Basse 56200,02000 112,4020,0%\\n
Heure Creuse Saison Basse 26840,01700 45,6320,0%\\n
Consommation du 01/08/22 au 13/08/22\\n
Heure Pleine Saison Basse 3
Heure Creuse Saison Basse 4
Heure Pleine Saison Basse 5
Heure Pleine Saison Basse 6
Heure Pleine Saison Basse 7
Services et prestations techniques conso\\n
kWh/Qté prix unitaire\\n
HT en euros montant HT\\n
en euros taux de\\n
TVA\\n
Espace Client Gratuit\\n
Taxes et Contributions conso\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}