using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^UA-(\d{4,10})-(\d{1,4})\b$";
string input = @"ua-1234567890-1234";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}