const regex = /^UA-(\d{4,10})-(\d{1,4})\b$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^UA-(\\d{4,10})-(\\d{1,4})\\b$', 'gmi')
const str = `ua-1234567890-1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}