package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^UA-(\d{4,10})-(\d{1,4})\b$`)
var str = `ua-1234567890-1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}