$re = '/^UA-(\d{4,10})-(\d{1,4})\b$/mi';
$str = 'ua-1234567890-1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);