#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)filter.........([^"]*)"
Local $sString = "{" & @CRLF & _
" "bridge": {" & @CRLF & _
" "name": "Homebridge"," & @CRLF & _
" "username": "XX:22:3D:XX:CE:31"," & @CRLF & _
" "port": 51826," & @CRLF & _
" "pin": "031-45-154"" & @CRLF & _
" }," & @CRLF & _
"" & @CRLF & _
" "platforms": [" & @CRLF & _
" {" & @CRLF & _
" "platform": "FHEM"," & @CRLF & _
" "name": "FHEM"," & @CRLF & _
" "server": "127.0.0.1"," & @CRLF & _
" "port": "8083"," & @CRLF & _
" "auth": {"user": "Bernd", "pass": "xxxxx"}," & @CRLF & _
" "filter": "room=Homekit"" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
"" & @CRLF & _
" "accessories": []" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")