package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)filter.........([^"]*)`)
var str = `{
"bridge": {
"name": "Homebridge",
"username": "XX:22:3D:XX:CE:31",
"port": 51826,
"pin": "031-45-154"
},
"platforms": [
{
"platform": "FHEM",
"name": "FHEM",
"server": "127.0.0.1",
"port": "8083",
"auth": {"user": "Bernd", "pass": "xxxxx"},
"filter": "room=Homekit"
}
],
"accessories": []
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}