const regex = /filter.........([^"]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('filter.........([^"]*)', 'gm')
const str = `{
"bridge": {
"name": "Homebridge",
"username": "XX:22:3D:XX:CE:31",
"port": 51826,
"pin": "031-45-154"
},
"platforms": [
{
"platform": "FHEM",
"name": "FHEM",
"server": "127.0.0.1",
"port": "8083",
"auth": {"user": "Bernd", "pass": "xxxxx"},
"filter": "room=Homekit"
}
],
"accessories": []
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}