using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<type>RESERVED)(?:::)(?P<desc>[\w#()/]*)";
string input = @"RESERVED::NETWORK_MIGRATION
RESERVED::ASBX_CO_01_MIGRATION";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}