// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<type>RESERVED)(?:::)(?P<desc>[\w#()/]*)").unwrap();
let string = "RESERVED::NETWORK_MIGRATION
RESERVED::ASBX_CO_01_MIGRATION";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}