import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[_]*([^|\\n]+)[^\\.\\n]*?([^|\\n]{3,})$";
final String string = "___your library open|rr||ahk|run,SourceTree.txt\n"
+ "autoload.ahk\n"
+ "b&w Wordlists|r|E:\\fre\\Wordlists\\TscShellContainerClass\n"
+ "Visual Basic|rr||ahk|q=b&w Wordlists\n"
+ "Recent|r|C:\\Users\\bla\\AppData\\Roaming\\Microsoft\\Windows\\Recent\n"
+ "last used Recent|rr||ahk|q=Recent\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}