use strict;
my $str = '___your library open|rr||ahk|run,SourceTree.txt
autoload.ahk
b&w Wordlists|r|E:\\fre\\Wordlists\\TscShellContainerClass
Visual Basic|rr||ahk|q=b&w Wordlists
Recent|r|C:\\Users\\bla\\AppData\\Roaming\\Microsoft\\Windows\\Recent
last used Recent|rr||ahk|q=Recent
';
my $regex = qr`^[_]*([^|\n]+)[^\.\n]*?([^|\n]{3,})$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}