const regex = new RegExp('^[_]*([^|\\n]+)[^\\.\\n]*?([^|\\n]{3,})$', 'gm')
const str = `___your library open|rr||ahk|run,SourceTree.txt
autoload.ahk
b&w Wordlists|r|E:\\fre\\Wordlists\\TscShellContainerClass
Visual Basic|rr||ahk|q=b&w Wordlists
Recent|r|C:\\Users\\bla\\AppData\\Roaming\\Microsoft\\Windows\\Recent
last used Recent|rr||ahk|q=Recent
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}