$re = '`^[_]*([^|\n]+)[^\.\n]*?([^|\n]{3,})$`m';
$str = '___your library open|rr||ahk|run,SourceTree.txt
autoload.ahk
b&w Wordlists|r|E:\\fre\\Wordlists\\TscShellContainerClass
Visual Basic|rr||ahk|q=b&w Wordlists
Recent|r|C:\\Users\\bla\\AppData\\Roaming\\Microsoft\\Windows\\Recent
last used Recent|rr||ahk|q=Recent
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);