#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[_]*([^|\n]+)[^\.\n]*?([^|\n]{3,})$"
Local $sString = "___your library open|rr||ahk|run,SourceTree.txt" & @CRLF & _
"Simple" & @CRLF & _
"Simple Text is not good to read with this regExpression." & @CRLF & _
"" & @CRLF & _
"autoload.ahk" & @CRLF & _
"b&w Wordlists|r|E:\fre\Wordlists\TscShellContainerClass" & @CRLF & _
"Visual Basic|rr||ahk|q=b&w Wordlists" & @CRLF & _
"Recent|r|C:\Users\bla\AppData\Roaming\Microsoft\Windows\Recent" & @CRLF & _
"last used Recent|rr||ahk|q=Recent" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")