re = /^[_]*([^|\n]+)[^\.\n]*?([^|\n]{3,})$/m
str = '___your library open|rr||ahk|run,SourceTree.txt
Simple
Simple Text is not good to read with this regExpression.
autoload.ahk
b&w Wordlists|r|E:\\fre\\Wordlists\\TscShellContainerClass
Visual Basic|rr||ahk|q=b&w Wordlists
Recent|r|C:\\Users\\bla\\AppData\\Roaming\\Microsoft\\Windows\\Recent
last used Recent|rr||ahk|q=Recent
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end