import re
regex = re.compile(r"^[_]*([^|\n]+)[^\.\n]*?([^|\n]{3,})$", flags=re.MULTILINE)
test_str = ("___your library open|rr||ahk|run,SourceTree.txt\n"
"Simple\n"
"Simple Text is not good to read with this regExpression.\n\n"
"autoload.ahk\n"
"b&w Wordlists|r|E:\\fre\\Wordlists\\TscShellContainerClass\n"
"Visual Basic|rr||ahk|q=b&w Wordlists\n"
"Recent|r|C:\\Users\\bla\\AppData\\Roaming\\Microsoft\\Windows\\Recent\n"
"last used Recent|rr||ahk|q=Recent\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")