package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[_]*([^|\n]+)[^\.\n]*?([^|\n]{3,})$`)
var str = `___your library open|rr||ahk|run,SourceTree.txt
Simple
Simple Text is not good to read with this regExpression.
autoload.ahk
b&w Wordlists|r|E:\fre\Wordlists\TscShellContainerClass
Visual Basic|rr||ahk|q=b&w Wordlists
Recent|r|C:\Users\bla\AppData\Roaming\Microsoft\Windows\Recent
last used Recent|rr||ahk|q=Recent
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}