using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<[^<>]*>|&\w+;)(*SKIP)(*F)|\bmicro\b";
string input = @"<the tags> or µ micro microscope Cosmicros";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}