re = /(?:<[^<>]*>|&\w+;)(*SKIP)(*F)|\bmicro\b/m
str = '<the tags> or µ micro microscope Cosmicros'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end