$re = '/(?:<[^<>]*>|&\w+;)(*SKIP)(*F)|\bmicro\b/m';
$str = '<the tags> or µ micro microscope Cosmicros';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);