package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:<[^<>]*>|&\w+;)(*SKIP)(*F)|\bmicro\b`)
var str = `<the tags> or µ micro microscope Cosmicros`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}