using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(domain1|domain2|domain3).(com|net|org|com\.au) Final Notice";
string input = @"Domain1.com Final Notice";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}