$re = '/(domain1|domain2|domain3).(com|net|org|com\.au) Final Notice/i';
$str = 'Domain1.com Final Notice';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);