package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(domain1|domain2|domain3).(com|net|org|com\.au) Final Notice`)
var str = `Domain1.com Final Notice`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}