package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^( *[\w+-.%]+@[\w-.]+\.[A-Za-z]{2,4}( *, *)? *)+$`)
var str = ` aa@sss.ru,aa@dd.ru , dd@ss.com,22@dd.ei `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}